{1 - 24} GreyGrey
{25 - 49} GreenGreen
{50 - 499} BlueBlue
{500 - 4999} OrangeOrange
{5000 - 24999} RedRed
{25000+} BlackBlack

Please confirm that you would like to report this for an admin to review.


Cavitron jet plus dentsply

Anyone who uses Cavitron jet plus by dentsply Sirona have issues with water flow? We have sent this unit back 3 times for same issue (no water flow to unit – won’t even purge) and now we just got it back and same issue is happening already. Just wondering if anyone has experienced same issue/any insight on how to fix problem! Our rep has told us to make sure we are changing filter, auto claving hand piece etc and we are doing so at appropriate intervals! I can’t help but to think I am the problem! Although I really don’t think I am since I have been in other ops at my office and have used a different unit for months at a time with no issue! Just not getting very far with dentsply so if anyone has a solution would love the help! 🙂



Confirm that you would like to Remove Email Alerts for your question. You cant undo this and you will not be able to re-subscribe.


1 Answer

It might be the waterline itself, not the unit. I would try hooking up a unit from a different op and seeing if it works to figure out if it’s the unit or waterline.

Confirm that you would like to select this answer as the "Best Answer" to your question. This will bring this answer to to top and be highlighted as "Best Answer". You can always change this if a better answer is given.


You must be Logged In to Answer this Question

Already a Member, Log In
Not a member yet? Sign Up